• photographeweb974
    12 juillet 2016 at 16 h 55 min #7895

    Depuis début Juillet, tous les sites sous OVH fonctionnent en https…

    Il faut donc faire un choix pour éviter le duplicate: redirection de http vers https ou l’inverse si on veut rester comme avant.
    Si vous voulez simplement supprimer le ssl gratuit ‘et sans certificat) c’est ici:
    https://www.ovh.com/fr/g1594.les_certificats_ssl_sur_les_hebergements_web

    Mais voilà, il y a des sites pour lesquels le https fonctionne bien et d’autres non:

    Fonctionne bien: https://www.locationsaisonniere974.com/

    Problème d’affichage de menus / icônes: https://www.hdoi360.com/

    https://faure.re/

    D’ou peuvent venir ces problèmes d’affichage en https ? OVH ? WordPress ? Jupiter ?
    Et comment le résoudre ?

    Philippe BERTIEAUX
    13 juillet 2016 at 1 h 18 min #7902

    Salut Christian.

    Un site,pour éviter la sanction du duplicate content de Google, doit fonctionner soit sous http://, soit sous https:// .
    Pour basculer de l’un à l’autre, il y a plusieurs possibilités assez radicales je dois dire :

    1) Par le fichier .HTACCESS situé à la racine des serveurs OVH. Une doc bien faite ici permet d’écrire quelques lignes de code permettant de régler ce soucis définitivement.

    2) Par l’installation d’une extension que j’utilise personnellement, et qui règle ça tout aussi bien : WordPress Force HTPPS, voir le lien ICI .

    Tiens-nous au courant Christian. Au pire, je checkerais directement ton code.

    Laetitia
    24 novembre 2016 at 19 h 21 min #7980

    Bonjour,

    Je viens d’installer WP Force HTPPS, et là, cata ! Toute la mise en page de mon site est partie en vrille et Yakaferci me signale une erreur 301 sous mon nom de domaine en https … (précision importante, je suis débutante 😉 ).
    Du coup, j’ai désactivé l’extension et tout va mieux… j’ai raté un truc, n’est ce pas ?

    Philippe BERTIEAUX
    25 novembre 2016 at 9 h 47 min #7981

    Bonjour Laetitia, c’est avec plaisir que je te souhaite la bienvenue sur ce forum.

    Alors : pour un passage complet et définitif en HTTPS, il faut réaliser sous wordpress 3 opérations simples qui interagissent entre elles.

    1) Il faut, sous l’espace client d’OVH, section Hébergement, activer le Certificat SSL. (On donne ainsi à OVH l’ordre d’autoriser l’accès au site par le protocole HTTPS)

    2) Sous la back office de WordPress, installer simplement le plug-in (extension) Force HTTPS.

    3) Puis normalement, il est également indispensable d’aller, toujours dans le BO, dans la section Réglages, Général, et ajouter le S manquant dans la rubrique “Adresse web de WordPress” et idem pour la rubrique “Adresse web du site (URL)”

    Une fois ces 3 opérations réalisées, une ré-authentification est demandée, mais cette fois, en HTTPS 🙂

    ENjoy !

    Laetitia
    25 novembre 2016 at 18 h 20 min #7982

    Bonjour Philippe,

    Un grand merci pour ta réponse ! En effet, j’avais raté l’étape 3 … maintenant, tout va mieux !

    J’ai remarqué quelques changements dans ma mise en page depuis le passage en HTTPS (ex, j’ai usé et abusé du pluggin Circle Image Frame, et mes “circles” se sont transformés en ovales avec la modif. Bon, rien de méchant, c’est sympa aussi, les ovales 😉 )

    Merci pour tes explications claires et efficaces !
    Laetitia

    Philippe BERTIEAUX
    28 novembre 2016 at 6 h 42 min #7985

    Ce fut avec plaisir 🙂 Comme d’habitude.

    Concernant les Circle Image Frame, peut-être une histoire de bug résiduel ? Vides ton cache ?

    Bonne et longue vie à ton site pro !

Vous devez être authentifié(e) pour participer à cette discussion.